Difference between revisions of "Installing Geeklog:System Requirements"

From GeeklogWiki
Jump to: navigation, search
m (Remove Spam)
(Installation - System Requirements)
 
(17 intermediate revisions by 3 users not shown)
Line 1: Line 1:
Geeklog requires PHP, MySQL and a webserver that works with these.
+
== Installation - System Requirements ==
  
PHP: The minimum PHP version required is PHP 4.0.4. However, that version is very much out of date (and has security issues), so we suggest you use PHP 4.1.2 at the very least. Or, better yet, use the most up to date version available at the time you're reading this.
+
The system requirements for installing Geeklog v2.2.1 (the last time the requirements changed) and later are as follows:
  
At the time of this writing, PHP 5 is still in Beta. As one of the main goals of PHP 5 development was to keep compatibility with PHP 4, we do not expect any serious problems with PHP 5. We plan to be fully compatible with PHP 5 when it is released.
+
# Web server - one of the following
 
+
## Apache Web Server
MySQL: While we try to be compatible with MySQL down to version 3.22, we recommend using the most up to date version of the 3.23 or 4.0 variety available at the time you're reading this.
+
## Microsoft IIS (Internet Information Server)
 
+
# PHP v5.6.4 or higher (including PHP v7) with the following extensions
Please note that because of possible SQL injection problems, we do not recommend using Geeklog on MySQL 4.1 (which is still in Alpha state at the time of this writing). We plan to resolve any outstanding issues with the release of Geeklog 1.3.9 in early 2004.
+
## mbstring Extension
 
+
## bzip2 Extension
Webserver: Geeklog is known to work with the Apache, Zeus, and Microsoft IIS webservers. As with the other components, it is suggested to use the most up to date version available at the time you're reading this.
+
## mysql or mysqli Extension (To enable MySQL support)
 
+
## pgsql Extension (To enable Postgresql support)
A note about Apache 2 compatibility: At the time of this writing, there was still no official word from the PHP developers regarding compatibility of PHP 4 and Apache 2. There are, however, several sites running without any problems on this combination. Again, it is suggested to use the most up to date version of both Apache and PHP.
+
## OpenSSL Extension (To enable the Geeklog OAuth Login process)
 +
## JSON Extension (For Filemanager and Database tools)
 +
## fileinfo (To enable thumbnail creation of images in articles) (for IIS only as fileinfo is integrated into Apache)
 +
## cURL (Not required but recommended for the reCaptcha plugin)
 +
# Database server - one of the following
 +
## MySQL 4.1.3 or higher (MySQL 5 recommended)
 +
## Postgresql 9.1.7 or later
 +
# The ability to create a new database or to have access to an existing one

Latest revision as of 21:50, 19 April 2020

Installation - System Requirements

The system requirements for installing Geeklog v2.2.1 (the last time the requirements changed) and later are as follows:

  1. Web server - one of the following
    1. Apache Web Server
    2. Microsoft IIS (Internet Information Server)
  2. PHP v5.6.4 or higher (including PHP v7) with the following extensions
    1. mbstring Extension
    2. bzip2 Extension
    3. mysql or mysqli Extension (To enable MySQL support)
    4. pgsql Extension (To enable Postgresql support)
    5. OpenSSL Extension (To enable the Geeklog OAuth Login process)
    6. JSON Extension (For Filemanager and Database tools)
    7. fileinfo (To enable thumbnail creation of images in articles) (for IIS only as fileinfo is integrated into Apache)
    8. cURL (Not required but recommended for the reCaptcha plugin)
  3. Database server - one of the following
    1. MySQL 4.1.3 or higher (MySQL 5 recommended)
    2. Postgresql 9.1.7 or later
  4. The ability to create a new database or to have access to an existing one