Installing Geeklog:System Requirements

From GeeklogWiki
Jump to: navigation, search

Installation - System Requirements

The system requirements for installing Geeklog 2.1.2 and later are as follows:

  1. Web server - one of the following
    1. Apache Web Server
    2. Microsoft IIS (Internet Information Server)
  2. PHP 5.3.3 or higher with the following extensions
    1. mbstring Extension
    2. bzip2 Extension
    3. mysql or mysqli Extension (To enable MySQL support)
    4. pgsql Extension (To enable Postgresql support)
    5. OpenSSL Extension (To enable the Geeklog OAuth Login process)
    6. JSON Extension (For Filemanager and Database tools)
  3. Database server - one of the following
    1. MySQL 4.1.3 or higher (MySQL 5 recommended)
    2. Postgresql 9.1.7 or later
  4. The ability to create a new database or to have access to an existing one
Personal tools
Namespaces

Variants
Actions
documentation
Tools