PHP 4 Support discontinued

From GeeklogWiki
Jump to: navigation, search

(this is a draft of a statement regarding dropping PHP 4 compatibility)

Starting with Geeklog 1.8.0, Geeklog will require PHP 5.2.0 or later to run. The last version of Geeklog to run on older PHP versions was 1.7.1, released Oct 31, 2010.

Support for PHP 4 by the PHP development team offically ended on December 31, 2007. A last official release, PHP 4.4.9, was made on August 8, 2008. Since then, no security or other bugfixes have been released for PHP 4.

Some Linux distributions with long-term support, most notably Red Hat Enterprise Linux 4 (RHEL 4) and CentOS 4 (others?), shipped with PHP 4 at the time they were released and have therefore committed to continue PHP 4 support until the end of their support period. Therefore, unfortunately, there are still "supported" PHP 4 installations out there.

As a compromise and service to those of our users being "stuck" on such a setup, the Geeklog Team will continue to provide security fixes for Geeklog 1.7 in a timely manner until February 29, 2012 (which coincides with the "End of Production 3 phase" for RHEL 4). Where by "timely", we mean "as soon as possible, but not necessarily on the same day as the then-current release". The further versions drift apart, the more work will it be for us to backport fixes.

Overall, however, we would really suggest that you switch to a host running PHP 5.2 or later, if at all possible and as soon as possible.

A note about PHP 4.3: Geeklog 1.7 requires PHP 4.4.0 to be installed. This requirement, however, really comes from the PEAR packages that we ship with Geeklog, not from Geeklog itself. So if you need to run Geeklog 1.7 on PHP 4.3, you could:

  • change the constant SUPPORTED_PHP_VER in lib-install.php to '4.3.0'
  • replace the contents of the system/pear directory with those from Geeklog 1.6.1